릴리즈 노트 - FreeBSD 릴리즈 3.5.1-RELEASE 3.5.1-RELEASE에 오신 것을 환영합니다. 이것은 1999년 12월에 릴리즈된 3.4-RELEASE의 후속 릴리즈입니다. 3.4 릴리즈 이후 몇달간 수많은 버그 수정과 일반적인 기능 향상이 있었습니다. 자세한 내용은 아래에서 보세요. 일체의 설치 실패나 동작오류를 send-pr 명령어를 사용해 (혹은 WEB 기반의 인터페이스는 http://www.freebsd.org/send-pr.html에서 보실 수 있습니다.) 저희에게 알려주시기를 부탁드립니다. FreeBSD에 대한 정보, 3.5.1-RELEASE 디렉토리의 구성에 대해서는 (특히 플로피로 설치를 하고자 한다면 특별히!), ABOUT.TXT를 보시기 바랍니다. 설치에 관한 일체의 설명은, INSTALL.TXT와 HARDWARE.TXT 파일을 보도록 하십시오. 차례: ------------------ 1. 3.4-RELEASE 이후로 새로워진 점 1.1 커널 측면 1.2 보안 측면 1.3 사용자 측면 2. 지원하는 설정 2.1 디스크 콘트롤러 2.2 이더넷 카드 2.3 ATM 2.4 기타 장치 3. FreeBSD를 구하는 방법 3.1 FTP/전자우편 3.2 CDROM 4. FreeBSD의 이전 릴리즈에서 업그레이드 5. 문제점 보고, 제안, 코드 제공 6. 감사 1. 3.4-RELEASE 이후로 새로워진 점 --------------------------------- 1.1. 커널 측면 -------------- 로더가 -current에서 많이 갱신. CAM 드라이버의 여러 버그가 수정. oltr [Olicom NIC] 드라이버가 갱신. bktr(4) [Brooktree 프레임 그래버] 드라이버가 갱신. isp(4) [Compaq Qlogic] 드라이버가 갱신. sym(4) [NCR/Symbios SCSI 콘트롤러] 드라이버가 갱신. syscons(4)의 많은 버그가 수정. vinum(4)의 많은 버그가 수정. wd(4) 드라이버에서 LBA를 더 잘 지원. 오디오 믹서 mixer(8) 지원이 많이 갱신. 마이크로소프트 사운드 소스(MSS) 오디오 장치 지원. 리눅스 호환 코드에서 더 많은 리눅스 시스템 콜 지원. netgraph(4) 갱신되었습니다; 새 노드 타입과 문서가 추가. msdosfs 코드의 여러 버그 수정. 1.2. 보안 측면 -------------- 작지만 많은 수정이 있어서 모두 나열하기는 힘듭니다. 자세한 사항은 CVS 저장소를 보세요. 사용자 측면에서는 "여러가지 것들이 많이 수정되었습니다" 정도면 충분할 것입니다. 1.3. 사용자 측면 ---------------- vinum(8)이 크게 갱신. chmod(1)에 -v 플래그가 추가. 자세한것은 매뉴얼 페이지를 보세요. df(1)에 새 유니트 타입이 추가. 자세한것은 매뉴얼 페이지를 보세요. ppp(1)이 크게 갱신. date(1), ed(1), ln(1), sh(1), camcontrol(8), vinum(8)과 수많은 사용자 명령어의 여러가지 버그 수정(자세한 사항은 CVS를 보세요 :) groff(1), grep(1), texinfo(1) 유틸리티 갱신. -current에서 /etc 의 여러가지 사항 갱신. 매뉴얼 페이지의 여러 문서 버그 수정. 동적 링커에 스레드 락킹 함수 추가(dllockinit(3)을 보세요). pthread_cancel(3) 함수 추가. ppp(8)에 몇가지 변경과 버그 수정이 있었습니다. 하나는 특히 기존의 설정을 방해할 수 있습니다. # 문자는 이제 행 가장 처음이 아니더라도 주석문의 시작으로 간주됩니다. 일부 ISP는 사용자 인증 이름(authname)에 # 문자를 쓰는 경우가 있습니다. 이런 것은 에스케이프 처리(앞에 \를 붙임)나 인용문자(")를 써야 합니다. picobsd 지원(/usr/src/release/picobsd)이 크게 갱신. 시스템 설치에 HTTP 설치 옵션 추가(sysinstall(8)). XFree86이 3.3.5에서 3.3.6으로 갱신(XFree86 4.0은 아직 본격적으로 쓰일 때가 아닙니다). 2. 지원하는 설정 ---------------- FreeBSD는 386sx에서 펜티엄(Pentium)에 이르기까지 (비록 386sx를 추천하지는 않지만) ISA, VLB, EISA과 PCI bus 기반의 매우 다양한 PC에서 작동합니다. 보통의 IDE나 ESDI 드라이브 장치, 다양한 SCSI 컨트롤러, 네트워크와 직렬 카드도 지원됩니다. 다음은 현재 FreeBSD에서 작동되는 것으로 확인된 주변장치들의 목록입니다. 작동하는 다른 기기도 있겠지만, 단지 확인되지 않은 것일 뿐입니다. 2.1. 디스크 콘트롤러 -------------------- WD1003 (일반적인 MFM/RLL) WD1007 (일반적인 IDE/ESDI) IDE ATA Adaptec 1535 ISA SCSI 컨트롤러 Adaptec 154x 시리즈 ISA SCSI 컨트롤러 Adaptec 174x 시리즈 표준, 확장 모드의 EISA SCSI 컨트롤러 Adaptec 274x/284x/2920C/294x/2950/3940/3950 (Narrow/Wide/Twin) 시리즈 EISA/ISA/EISA/PCI 콘트롤러. Adaptec AIC7850, AIC7860, AIC7880, AIC789x, 내장 SCSI 컨트롤러 Adaptec 1510 시리즈 ISA SCSI 콘트롤러 (부팅 가능 장치 제외) Adaptec 152x 시리즈 ISA SCSI 콘트롤러 Adaptec AIC-6260와 AIC-6360기반 보드(AHA-152x와 SoundBlaster SCSI 카드 포함) AdvanSys SCSI 콘트롤러 (모든 모델). BusLogic MultiMaster 콘트롤러: [ BusLogic/Mylex "Flashpoint" 아답터는 아직 지원하지 *않습니다* ] BusLogic MultiMaster "W" 시리즈 호스트 아답터: BT-948, BT-958, BT-958D BusLogic MultiMaster "C" 시리즈 호스트 아답터: BT-946C, BT-956C, BT-956CD, BT-445C, BT-747C, BT-757C, BT-757CD, BT-545C, BT-540CF BusLogic MultiMaster "S" 시리즈 호스트 아답터: BT-445S, BT-747S, BT-747D, BT-757S, BT-757D, BT-545S, BT-542D, BT-742A, BT-542B BusLogic MultiMaster "A" 시리즈 호스트 아답터: BT-742A, BT-542B 완전한 BusLogic MultiMaster의 복제품인 AMI FastDisk 콘트롤러도 지원합니다. DPT SmartCACHE Plus, SmartCACHE III, SmartRAID III, SmartCACHE IV, SmartRAID IV SCSI/RAID 콘트롤러를 지원합니다. DPT SmartRAID/CACHE V 는 아직 지원하지 않습니다. SymBios (이전 NCR) 53C810, 53C810a, 53C815, 53C820, 53C825a, 53C860, 53C875, 53C875j, 53C885, 53C895, 53C896 PCI SCSI 콘트롤러: ASUS SC-200 Data Technology DTC3130 (모든 종류) Diamond FirePort (전부) NCR 카드 (전부) Symbios 카드 (전부) Tekram DC390W, 390U, 390F Tyan S1365 QLogic 1020, 1040, 1040B, 1080, 1240 SCSI 호스트 아답터. QLogic 2100 파이버 채널 아답터(프라이빗 루프만). 1542에뮬레이션 모드의 DTC 3290 EISA SCSI 콘트롤러. 지원하는 모든 SCSI 콘트롤러 중에서 완전히 지원하는 것은 하드디스크, 광디스크, 테이프 드라이브(DAT와 8mm Exabyte포함), 매체 교환기, 프로세스 타겟 장치와 CDROM 드라이브를 포함하는 SCSI-I과 SCSI-II 주변기기입니다. CDROM 명령을 지원하는 WORM장치는 CDROM 드라이버를 사용하여 읽기 전용 장치로 지원합니다. WORM/CD-R/CD-RW 기록 기능 지원은 포트 트리에 있는 cdrecord 프로그램이 제공합니다. 현재 다음의 CD-ROM 타입 시스템을 지원합니다: (cd) SCSI 인터페이스 (ProAudio Spectrum과 SoundBlaster SCSI도 포함) (matcd) Matsushita/Panasonic (Creative SoundBlaster) 전용 인터페이스 (562/563 모델) (scd) Sony proprietary 인터페이스 (전 모델) (wcd) ATAPI IDE 인터페이스 다음 드라이버는 이전 SCSI 부시스템에서 지원하는 것이었으나 새로운 CAM SCSI 부시스템에서는 아직 지원하지 않습니다: NCR5380/NCR53400 ("ProAudio Spectrum") SCSI 콘트롤러. UltraStor 14F, 24F, 34F SCSI 콘트롤러. Seagate ST01/02 SCSI 콘트롤러. Future Domain 8xx/950 시리즈 SCSI 콘트롤러. WD7000 SCSI 콘트롤러. [ 주의: UltraStor 드라이버를 새 CAM SCSI 프레임워크에 포팅하려는 작업이 진행중입니다만, 언제 끝날지, 정말 끝날지의 여부에 대해서는 알 수 없습니다. ] 하드웨어에 따라 동작하지 않을 수도 있는 관리되지 않는 드라이버: 플로피 테이프 인터페이스 (Colorado/Mountain/Insight) (mcd) Mitsumi 전용 CD-ROM 인터페이스 (전 모델) 2.2. 이더넷 카드 ---------------- Adaptec AIC-6915 고속 이더넷 콘트롤러 칩 기반의 Adaptec Duralink PCI 고속 이더넷 아답터: ANA-62011 64-bit 싱글 포트 10/100-BaseTX 아답터 ANA-62022 64-bit 듀얼 포트 10/100-BaseTX 아답터 ANA-62044 64-bit 4 포트 10/100-BaseTX 아답터 ANA-69011 32-bit 싱글 포트 10/100-BaseTX 아답터 ANA-62020 64-bit 싱글 포트 100-BaseFX 아답터 Allied-Telesyn AT1700, RE2000 카드 Tigon 1, Tigon 2 칩셋에 기반한 Alteon Networks PCI 기가비트 이더넷 NIC: Alteon AceNIC (Tigon 1, 2) 3Com 3c985-SX (Tigon 1, 2) Netgear GA620 (Tigon 2) Silicon Graphics Gigabit Ethernet DEC/Compaq EtherWORKS 1000 NEC Gigabit Ethernet AMD PCnet/PCI (79c970 & 53c974, 79c974) SMC Elite 16 WD8013 이더넷 인터페이스, 그리고 대부분의 다른 WD8003E, WD8003EBT, WD8003W, WD8013W, WD8003S, WD8003SBT, WD8013EBT 기반 복제품. SMC Elite Ultra. SMC Etherpower II. RealTek 8129/8139 고속 이더넷 NIC: Allied Telesyn AT2550 Allied Telesyn AT2500TX Genius GF100TXR (RTL8139) NDC Communications NE100TX-E OvisLink LEF-8129TX OvisLink LEF-8139TX Netronix Inc. EA-1210 NetEther 10/100 KTX-9130TX 10/100 Fast Ethernet Accton "Cheetah" EN1027D (MPX 5030/5038; RealTek 8139 복제품?) SMC EZ Card 10/100 PCI 1211-TX Lite-On 82c168/82c169 PNIC 고속 이더넷 NIC: LinkSys EtherFast LNE100TX NetGear FA310-TX Rev. D1 Matrox FastNIC 10/100 Kingston KNE110TX Macronix 98713, 98713A, 98715, 98715A, 98725 고속 이더넷 NIC NDC Communications SFA100A (98713A) CNet Pro120A (98713, 98713A) CNet Pro120B (98715) SVEC PN102TX (98713) Macronix/Lite-On PNIC II LC82C115 고속 이더넷 NIC LinkSys EtherFast LNE100TX 버전 2 Winbond W89C840F 고속 이더넷 NIC: Trendware TE100-PCIE VIA Technologies VT3043 "Rhine I"과 VT86C100A "Rhine II" 고속 이더넷 NIC: Hawking Technologies PN102TX D-Link DFE-530TX Silicon Integrated Systems SiS 900과 SiS 7016 PCI 고속 이더넷 NIC Sundance Technologies ST201 PCI 고속 이더넷 NIC: D-Link DFE-550TX SysKonnect SK-984x PCI 기가비트 이더넷 카드 SK-9841 1000baseLX 싱글 모드 파이버, 싱글 포트 SK-9842 1000baseSX 멀티 모드 파이버, 싱글 포트 SK-9843 1000baseLX 싱글 모드 파이버, 듀얼 포트 SK-9844 1000baseSX 멀티 모드 파이버, 듀얼 포트 Texas Instruments ThunderLAN PCI NIC: Compaq Netelligent 10, 10/100, 10/100 Proliant, 10/100 Dual-Port Compaq Netelligent 10/100 TX Embedded UTP, 10 T PCI UTP/Coax, 10/100 TX UTP Compaq NetFlex 3P, 3P Integrated, 3P w/ BNC Olicom OC-2135/2138, OC-2325, OC-2326 10/100 TX UTP Racore 8165 10/100-BaseTX Racore 8148 10-BaseT/100-BaseTX/100-BaseFX multi-personality ADMtek Inc. AL981 기반 PCI 고속 이더넷 카드 ADMtek Inc. AN985 기반 PCI 고속 이더넷 카드 ASIX Electronics AX88140A PCI NIC: Alfa Inc. GFC2204 CNet Pro110B DEC EtherWORKS III NIC (DE203, DE204, DE205) DEC EtherWORKS II NIC (DE200, DE201, DE202, DE422) DEC DC21040, DC21041, DC21140 기반 NIC (SMC Etherpower 8432T, DE245 등등) DEC FDDI (DEFPA/DEFEA) NIC Fujitsu MB86960A/MB86965A HP PC Lan+ 카드 (모델명: 27247B, 27252A). Intel EtherExpress 16 Intel EtherExpress Pro/10 Intel EtherExpress Pro/100B PCI Fast Ethernet Isolan AT 4141-0 (16 비트) Isolink 4110 (8 비트) Novell NE1000, NE2000, NE2100 이더넷 인터페이스 NE2000을 에뮬레이트하는 네트워크 카드: RealTek 8029, NetVin 5000, Winbond W89C940, Surecom NE-34, VIA VT86C926. 3Com 3C501 카드 3Com 3C503 Etherlink II 3Com 3c505 Etherlink/+ 3Com 3C507 Etherlink 16/TP 3Com 3C509, 3C579, 3C589 (PCMCIA), 3C590/592/595/900/905/905B/905C PCI와 EISA (고속) Etherlink III / (고속) Etherlink XL 3Com 3c980/3c980B Fast Etherlink XL 서버 아답터 3Com 3cSOHO100-TX OfficeConnect 아답터 Toshiba 이더넷 카드 Crystal Semiconductor CS89x0-기반 NIC: IBM Etherjet ISA IBM 과 National Semicondutor 의 PCMCIA Etherjet 카드들도 지원합니다. (역주: NIC : 네트워크 인터페이스 카드 고속 이더넷 카드 : 100Mbits/s 기반의 Fast 이더넷 카드) 2.3 ATM ------- o ATM 호스트 인터페이스 - FORE Systems, Inc. PCA-200E ATM PCI 아답터 - Efficient Networks, Inc. ENI-155p ATM PCI 아답터 o ATM 시그널링 프로토콜 - ATM Forum UNI 3.1 시그널링 프로토콜 - ATM Forum UNI 3.0 시그널링 프로토콜 - ATM Forum ILMI 주소 등록 - FORE Systems의 전용 SPANS 시그널링 프로토콜 - Permanent Virtual Channels (PVCs) o IETF "ATM상의 고전적 IP와 ARP" 모델 - RFC 1483, "Multi-protocol Encapsulation over ATM Adaptation Layer 5" - RFC 1577, "Classical IP and ARP over ATM" - RFC 1626, "Default IP MTU for use over ATM AAL5" - RFC 1755, "ATM Signaling Support for IP over ATM" - RFC 2225, "Classical IP and ARP over ATM" - RFC 2334, "Server Cache Synchronization Protocol (SCSP)" - Internet Draft draft-ietf-ion-scsp-atmarp-00.txt, "A Distributed ATMARP Service Using SCSP" o ATM 소켓 인터페이스 2.4. 기타 장치 -------------- 공유 IRQ를 사용하는 AST 4 포트 직렬 카드 공유 IRQ를 사용하는 ARNET 8 포트 직렬카드 ARNET (현재 Digiboard) Sync 570/i 고속 직렬 Boca BB1004 4-포트 직렬 카드 (모뎀 지원 안됨) Boca IQAT66 6-포트 직렬 카드 (모뎀 지원됨) Boca BB1008 8-포트 직렬 카드 (모뎀 지원 안됨) Boca BB2016 16-포트 직렬 카드 (모뎀 지원됨) Comtrol Rocketport 카드 Cyclades Cyclom-y 직렬 보드 공유 IRQ를 사용하는 STB 4 포트 카드 SDL Communications Riscom/8 직렬 보드 SDL Communications RISCom/N2, N2pci 고속 동기 직렬 보드 Stallion 다중포트 직렬 보드 : EasyIO, EasyConnection 8/32 & 8/64, ONboard 4/16 그리고 Brumby. Specialix SI/XIO/SX ISA, EISA, PCI 직렬 확장 카드/모듈. Adlib, SoundBlaster, SoundBlaster Pro, ProAudioSpectrum, Gravis UltraSound 와 Roland MPU-401 사운드 카드. (snd 드라이버) Crystal Semiconductors, OPTi, Creative Labs, Avance, Yamaha, ENSONIQ 에서 만든 대부분의 ISA 오디오 코덱. (pcm driver) Connectix QuickCam Matrox Meteor Video 프레임 그래버 Creadtive Las Video Spigot 프레임 그래버 Cortex1 프레임 그래버 Hauppauge Wincast/TV 보드 (PCI) STB TV PCI Intel Smart Video Recorder III Brooktree Bt848/Bt878 칩에 기반한 다양한 프레임 그래버 HP4020, HP6020, Philips CDD2000/CDD2660, Plasmon CD-R 드라이브. PS/2 마우스 표준 PC 조이스틱 X-10 파워 컨트롤러 GPIB 와 Transputer 드라이버 Genius 와 Mustek 핸드 스캐너 Virtual Computers (www.vcc.com)의 HOT1과 호환 가능한 Xilinx XC6200 기반 재설정 가능한 하드웨어 카드 Dave Mills 실험적 Loran-C 리시버. Lucent Technologies WaveLAN/IEEE 802.11 PCMCIA와 ISA 표준 속도(2Mbps) 와 터보 속도(6Mbps) 무선 네트워크 아답터와 그 변종 (NCR WaveLAN/IEEE 802.11, Cabletron RoamAbout 802.11 DS). 주의: 이 아답터의 ISA 버전은 실제로 ISA - PCMCIA 브리지 카드와 결합된 PCMCIA 카드이므로, 두 종류의 장치가 같은 드라이버에서 작동합니다. FreeBSD는 현재 IBM의 마이크로채널(MCA) 버스를 지원하고 있지 *않습니다.* 3. FreeBSD를 구하는 방법 ------------------------ 다양한 방법으로 FreeBSD를 구할 수 있습니다. 3.1. FTP/전자우편 ----------------- `ftp.freebsd.org' - FreeBSD 공식 배포 사이트 - 에서 ftp 로 FreeBSD와 추가적인 패키지를 일부 혹은 전부 전송 받을 수 있습니다. FreeBSD 소트프웨어를 복사해 놓은(mirror) 다른 곳에 대해서는 MIRROR.SITES 파일을 참조하십시오. 가능하다면 가장 가까운 곳으서(네트워크 상에서) 배포본을 받기를 바랍니다. 추가 미러 사이트(mirror site)는 언제나 환영합니다! 공식 미러 사이트가 되려면 보다 자세한 것에 대해 freebsd-admin@FreeBSD.org 와 연락을 취하십시오. 인터넷을 사용할 수 없고 전자우편만 사용할 수 있다면, 그래도 `ftpmail@ftpmail.vix.com'으로 전자우편을 보내어서 파일을 받을 수 있습니다 - 메시지에 "help"라는 키워드를 적어 보내면 이 방법을 사용해서 파일을 어떻게 얻는지에 대한 자세한 정보를 얻을 수 있습니다. 그러나, 이 방법은 전자우편을 통해 *수십 메가바이트의* 파일을 보내게 되므로 정말 최후의 방법으로만 사용되어야 합니다! 3.2. CDROM ---------- FreeBSD 3.5.1-RELEASE CD는 CDROM의 형태로 다음의 주소에서 주문할 수 있습니다: BSDi 4041 Pike Lane, Suite F Concord CA 94520 1-800-786-9907, +1-925-674-0783, +1-925-674-0821 (FAX) 또는 orders@osd.bsdi.com 또는 http://www.freebsdmall.com 에서 구할 수 있습니다. -RELEASE CD 한장당 가격은 $39.95 이고, FreeBSD 구독자의 경우는 한장당 $24.95 입니다. FreeBSD 3.0-SNAP CD의 경우 한장당 가격은 $39.95 이고, FreeBSD-SNAP 구독자의 경우는(-RELEASE와 -SNAP 구독은 전혀 다른 것입니다) 한장당 $14.95 입니다. 구독을 하는 경우 새로운 배포판이 나올 때마다 최신판을 담은 CD를 받게 됩니다. CD를 보낼 때 신용 카드로 대금이 지불되며 특별한 제한사항없이 어느 때나 구독을 취소할 수 있습니다. 운송료(CD당이 아니라 주문시마다)는 미국, 캐나다, 멕시코에서는 $5, 그밖의 나라에서는 $9.00 입니다. Visa, Matercard, Discover, American Express 또는 미국 달러의 수표와 미국내에 한해 Ship COD(배달시에 요금을 받는 방식)가 통용됩니다. 캘리포니아 거주자분들께서는 여기에 8.25%의 판매 세금을 더하십시오. 어떤 이유로 만족할 수 없다면 CD를 어떠한 조건도 없이 반환할 수 있습니다. 4. FreeBSD의 이전 릴리즈에서 업그레이드 --------------------------------------- 2.2.x나 2.1.x(그런 경우는 더 적지만)과 같은 FreeBSD의 이전 릴리즈에서 업그레이드하는 경우에는 다음의 몇가지 문제가 선택한 업그레이드 방법에 따라서 여러분에게 영향을 줄 수 있습니다. FreeBSD 배포본을 업그레이드 하는 방법에는 많이 사용하는 두가지가 있습니다: o /usr/src를 통해서 소스로 업그레이드하기 o sysinstall의 (바이너리) 업그레이드 옵션 소스를 사용하는 경우, 신경써 주어야 하는 두가지 타겟이 있습니다: 표준 ``upgrade'' 타겟은, 2.x나 3.0시스템을 3.5로 업그레이드하는 것이며, ``world'' 타겟은 이미 업그레이드된 시스템을 최초 업그레이드 이후에 일어난 변경 사항과 보조를 맞추도록 하는 것입니다. 바이너리 업그레이드 옵션을 사용하는 경우, 시스템은 곧바로 3.5/ELF로 이동합니다만 이전 바이너리와의 하위 호환성을 위해 //lib/aout도 만들어냅니다. 두 경우 모두 ELF로 이동하면, 바이너리 크기가 조금 작아지며 이미 다른 ELF 환경에 포팅된 여러가지 컴파일러 보조 도구를 사용할 수 있게 됩니다(우리의 오래되고 지저분한 a.out포맷은 대부분의 다른 소프트웨어 프로젝트에서 지원하지 않습니다). 이전의 a.out 동적 실행 파일을 사용하고 싶은 사람은 반드시 compat22 배포본이 설치되었는지 확인해야 합니다. 시스템이 다시 부팅되어야 a.out 라이브러리를 사용할 수 있으므로, 몇가지 a.out 패키지에 대해서는 문제를 일으킬 수도 있습니다. 또한, 이전 버전에서의 설치 디스크나 sysinstall을 사용하지 마세요. 버전 3.1부터 새로운 부트 과정이 제공되므로, 새 부트 블럭이 설치되어야 합니다(elf 커널 때문에). 또한 버전 3.2는 부트 과정에 더 많은 변경이 있었습니다. [ 중요한 다른 업그레이드 노트는 여기 있어야 합니다 ] 5. 문제점 보고, 제안, 코드 제공 ------------------------------- 언제 어느때나 제안을 하거나, 버그를 알리거나 코드를 기부하셔도 좋습니다. - 만약 문제를 발견했다면 꼭 알려주시길 바랍니다(가급적이면 그 해결책도 첨부해서!). 인터넷 전자우편이 연결되어 있는 컴퓨터로 버그를 보고하는 경우 권장하는 방법은 send-pr 명령을 이용하거나 http://www.freebsd.org/send-pr.html 에 있는 CGI 스크립트를 이용하는 것입니다. 버그 리포트는 믿을만한 버그 정리 프로그램에 의해 충실히 모아질 것이고 가능한한 빨리 보고된 버그에 대해 답신을 할 것을 약속합니다. 이렇게 정리된 문제들은 또한 우리 웹사이트의 지원부에서 볼 수 있는데 이는 주의해야할 잠제적 문제들을 지니고 있는 다른 사용자들에게 있어서 "길잡이"로도 유용합니다. 혹시나 어떤 이유로 버그 리포트를 보내는데 send-pr 명령을 쓸 수가 없다면 다음 주소로 편지를 보내도 좋습니다: freebsd-bugs@FreeBSD.org send-pr 은 그 자체가 전혀 다른 시스템에도 옮기기 쉬운 쉘 스크립트(shell script)라는 것을 상기하십시오. 이는 리포트의 형식을 유지하기 쉽게 하므로 이 인터페이스(send-pr)를 이용할 것을 부탁드립니다. 하지만, 보내시기 전에 한번 더 이미 해결된 문제인지 확인하길 바랍니다. 또, 어떤 질문이나 기술 지원 문제에 대해서는 다음 주소로 편지를 보내십시오: freebsd-questions@FreeBSD.org 덧붙여, 도우미의 노력이 있어 우리는 언제나 도움을 주려는 손길에 행복합니다. - 이미 우리들만으로 할 수 있었던 것과는 비교할 수도 없는 발전이 있었습니다! 전문적인 부분에 대해 연락을 하려거나 도움을 주시려면 다음 주소로 편지를 보내주십시오: freebsd-hackers@FreeBSD.org 이러한 메일링리스트는 *상당한* 수준의 정체를 일으킬 수 있다는 것을 명심하십시오. 만약 너무 느리거나 돈이 많이 드는 전자우편을 사용하고 있고, 중요한 FreeBSD 사안에 대해서만 관심이 있으시면 대신 다음의 주소에 등록하시는 것이 좋습니다: freebsd-announce@FreeBSD.org 모든 메일링 리스트는 가입하고자 하는 누구나 자유롭게 가입하실 수가 있습니다. 본문 어디에나 키워드 `help'를 적어서 MajorDomo@FreeBSD.org 로 편지를 보내십시오. 그러면 여러 메일링리스트에 가입, 문서의 이용 등에 관한 정보를 얻으실 수 있을 것입니다. 또한 여기서 언급하지 않은 특정 관심사를 다루는 메일링리스트가 많습니다. 그러한 것에 대해 majordomo 에게 질의하십시오(편지를 통해). (역주: 지역 정보는 한국 FreeBSD 사용자 그룹에서 제공하는 것입니다) 한국 내 사용자나 한국어를 사용하는 사용자는 한국 내 지역 미러 사이트인 http://www.kr.freebsd.org에서 많은 정보를 접할 수 있습니다. Korea FreeBSD Users Group(KFUG)은 현재 WWW/FTP/CVSup 미러 사이트와 사용자를 위한 메일링 리스트를 운영하고 있습니다. 자세한 정보는 다음 사이트에서 접하실 수 있습니다. WWW: http://www.kr.freebsd.org FTP: ftp://ftp.kr.freebsd.org 한국어 공지 메일링 리스트: announce@kr.freebsd.org 한국어 질의/응답 메일링 리스트: questions@kr.freebsd.org 6. 감사 ------- FreeBSD 는 수백 명은 아닐지라도 이 릴리즈를 제공하기 위해 매우 열심히 작업한 전세계 개개인의 수없이 누적된 성과물입니다. FreeBSD 프로젝트 일원의 전체 목록에 대해서는, 다음을 보십시오: http://www.freebsd.org/handbook/staff.html 또는 doc 배포본을 설치하셨다면: file:/usr/share/doc/handbook/staff.html 이분들에게 특별히 감사를 드리고 싶습니다: http://www.freebsd.org/handbook/donors.html 에 나열된 기증자들 그리고 전세계 수천의 FreeBSD 사용자들과 테스터들에게, 이들이 없었다면 이 릴리즈는 결코 가능하지 못했을 것입니다. 우리는 진심으로 이 FreeBSD 릴리즈를 즐기시길 바랍니다! FreeBSD 프로젝트 # $FreeBSD: src/release/texts/i386/RELNOTES.TXT,v 1.28.2.26 2000/06/25 00:20:48 jkh Exp $ # 역: 최준호 , 2000/1/19(3.4), 2000/7/21(2.5)